AnsweredAssumed Answered

Error archiving courses in REST/LTI Developer AMI

Question asked by sean on Jun 18, 2019
Latest reply on Jun 19, 2019 by sean

I originally put this question on the documentation for transferring data out of an EC2 instance, but I don't think it gets the visibility there of asking a question here. Sorry for posting in two spots, I can delete one or the other.

 

I am running into an error on step 4 of the EC2 data transfer doc using the 3500.5.0 REST/LTI Developer AMI. batch_ImportExport is running through my courses to archive them but I get this error on each course, example output for course_id 123:

Executed archive for 123 to /var/tmp/course_archives/

Operation output:

Jun 18, 2019 7:21:44 AM - [FATAL] Fatal: A fatal error that prevents processing from continuing has occurred. The reason for the error is:

Unable to create necessary temporary directory.

For more information, consult the detailed log.

Jun 18, 2019 7:21:44 AM - [WARNING] Status: The operation archive did not complete

 

The command I am running is:

sudo -u root /usr/local/blackboard/apps/content-exchange/bin/batch_ImportExport.sh -f /var/tmp/COURSES_Batch_Archive.txt -l 1 -t archive

 

This seems like it should be a simple permissions issue, but root owns /var/tmp and and the permissions are set to rwxrwxrwt. These should be the defaults as I haven't changed anything on the server related to permissions. I later tried creating a course_archives directory in /var/tmp, but the error is the same.

 

My COURSES_Batch_Archive.txt looks like this:

123,/var/tmp/course_archives/

but I also want to archive with grades and resources so I have also tried this

123,/var/tmp/course_archives/,true,true,true

 

I have tried archiving courses one at a time through the System Administration UI, and while it says it will email me when the archive is ready I never get an email and I don't see any downloads available on the archive page. The administrator user is using my correct email address.

 

Thanks for any advice on how to proceed.

Outcomes