AnsweredAssumed Answered

Is Content-Item Message for LTI placements working in 2018 Q2?

Question asked by mdeeprose on Sep 5, 2018
Latest reply on Sep 5, 2018 by mdeeprose

Hello everyone.

 

I have been beta-testing H5P.com but have hit an issue.

 

I have set up the LTI Tool Provider, but whenever I add a placement where Content-Item Message is selected as the Type, I receive a "ORA-02290: check constraint (BBLEARN1.SYS_C005720) violated" error.

 

I raised this to Bb support who informed me:

 

Response

Our Support, Engineering, and Product Management teams have carefully reviewed this issue and concluded that case 03153839 will be updated to Closed status as this will not be fixed in any upcoming releases. This decision was made based on one or more of the following criteria:

 

 

- The software defect has remained very low in priority across the install base of clients and has not been included in more than two Generally Available past releases after it was identified, or

 

 

- The software defect has been reported against features that have been discontinued or that have been rewritten in a more current release, or

 

 

- The software defect would require an unreasonable amount of engineering time and resources for a very marginal gain.

 

 

I have heard that other users beta testing H5P.com do not have this issue although I believe they are running SAAS or Managed Hosting platforms.

 

I'm trying to get to the bottom of this but am unsure where to turn.  Maybe Mark Kauffman Scott Hurrey or Mark O'Neil could shed some light on this.

 

I had the same issue with 2017 Q4 but had been told that it was resolved in 2018 Q2, but I'm still getting the error.  I also found https://blackboard.secure.force.com/btbb_articleview?id=kA339000000L6bK which suggests this was targeted to be fixed in 2017 Q4.

 

This is on a self-hosted, RHEL6, Oracle, installation.

Outcomes