AnsweredAssumed Answered

MyMessages B2 WAR file for Q4 2017 posted on OSCELOT

Question asked by rs0048203 on May 21, 2018
Latest reply on May 24, 2019 by rs0048203

On behalf of The University of New Mexico Information Technologies http://it.unm.edu, I have posted MyMessages B2 WAR file for Q2 2019 unm-unmmymessages-q2-2019.war (version 2.3.3-q4.2018) on OSCELOT https://github.com/OSCELOT/MyMessages

For Q4 2017 My Messages version 2.3.3-q4.2018 will not install (requires at least Q2 2018 Learn Release).

For Q4 2017 keep using My Messages version 2.3.1-q4.2017.

Please read the README file before installing (on a Test Server first).

Recommend to upgrade your existing My Messages to version 2.3.3-q4.2018 as soon as practical.

Note: This will first require to Upgrade Learn Release to at least Q2 2018 since My Messages version 2.3.1-q4.2017 will be deprecated effective November 27, 2019 because Q4 2017 is not supported as of December 2019.

My Messages (version 2.3.3-q4.2018) is not recommended for Q4 2019 since Q4 2019 is planned to use Java 11.  Plan to post another My Messages version for Java 11 about late December 2019.

Successfully tested My Messages (version 2.3.3-q4.2018) on a Q2 2019 (3700.0.0) Developer Virtual Machine.

Successfully tested My Messages (version 2.3.3-q4.2018) on Q4 2018 CU7 (3500.0.7) Developer Virtual Machine.

Successfully tested My Messages (version 2.3.3-q4.2018) on Q4 2018 CU6 (3500.0.6)

Successfully tested My Messages (version 2.3.3-q4.2018) on Q4 2018 CU5 (3500.0.5)

My Messages B2 will NOT work in Ultra (if your institution desires My Messages B2 for Ultra please reply below).

UNM is currently running My Messages B2 (version 2.3.3-q4.2018) on Production - Blackboard Learn Q4 2018 CU6 (Self Hosted).

Please reply below if you have successfully installed and tested My Messages (version 2.3.1-q4.2017) on any Self Hosted or Managed Hosted release (or if have issues).

Please mention: if you are Self Hosted or Managed Hosted; what Release.

Please reply to My Messages B2 for SaaS including plans to move to Java 11 (Original Experience) if you have successfully installed and tested My Messages (version 2.3.3-q4.2018) on any SaaS release (or if have issues).

My Messages is a rebuild (with modifications) of Bruce Tenison's (OSCELOT Archive) MyMessages B2 - Thank You Bruce!

My Messages rebuilt with Q4 2018 Building Block APIs: Building Blocks API 3500.0.0

1. Using updated B2Context version 1.9.00 - GitHub - OSCELOT/bb-b2context: This package provides basic support functions for Building Blocks.

Thanks Stephen Vickers and OSCELOT

2. Added Portuguese (Brazil) language, aka pt_BR, based on enhancement submission - Thanks to Diego Roberto de Sousa for translation.

Supplemental Information: My Messages

I made this post a question so Bb Community can post questions/comments.

Outcomes