mkauffman

NOTICE! No More HttpClient 3.x In Learn 3700.5.0 and Later

Blog Post created by mkauffman on Jul 13, 2019

I'm writing this to inform B2 developers that Blackboard has removed the Apache Commons HttpClient 3.x library from /usr/local/blackboard/systemlib in Blackboard Learn 3700.5.0. We are using HttpClient 4.x in Learn versions 3700.5.0 and later. 3700.5.0 has been in client-test since the 11th of June and went into production this last week on July 11. If your B2 depended on the HttpClient library that was in /usr/local/blackboard/systemlib and now gone, you will need to update it accordingly.

 

Here is a helpful blog post on the process of moving from HttpClient 3.x to 4.xhttps://blog.teamextension.com/migrating-from-httpclient-3-1-to-4-0-34 Note that this is NOT meant to be a cookbook on what to do, only an example of the types of things you might need to do. You will need to do your own research as a Java developer to make the changes to update to the HttpClient you do with.

 

In general: Third party developers should include, and keep up-to-date, all non-Blackboard-authored jars that they need in their .war files, even if one that they need happens to exist in the class path already.  Blackboard will be upgrading or removing these jars as required and without notice.

 

With the current pace of our SaaS deliveries, remember: Test early. Test often.

Outcomes